pyenvでpython実行したら「Python C API version mismatch for module fcntl …」とエラーになった

   2018/02/18

とあるpythonプログラムを実行しようとしたら、以下のようなエラーが出た。

_frozen_importlib:205: RuntimeWarning: Python C API version mismatch for module fcntl: This Python has API version 1013, module fcntl has version 1021.
Segmentation fault

いつのまにかどっかの設定が変わってしまったらしい。
色々調べたんだけど、いまいち「コレだ!」っていう対処法がなかったので、pythonを再インストールしてみた。

そしたら動くようになった。

この記事へのコメントはこちら

メールアドレスは公開されませんのでご安心ください。
また、* が付いている欄は必須項目となりますので、必ずご記入をお願いします。

内容に問題なければ、下記の「コメント送信」ボタンを押してください。

twelve + 3 =

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください