pyenvでpython2とpython3を同時に使う方法

   2018/01/20

python2からpython3しか対応してないライブラリを呼び出そうとして、うまくいかなかった時の話。

pyenvだと1つのバージョンしか指定できないと思ってたので、仕方なくjavaからpython3の処理を呼び出す方法に変えるとか色々やってみたけどうまくいかず・・・

うだうだと調べてたら、なんとpyenvで2つのバージョンを同時にglobalにできることが判明。

やり方としては、以下のようにコマンドを打つだけ。

最高かよ・・・
globalにこんな指定方法があったとはね。

ちなみに、2系をデフォにしたまま3系を呼び出すには、

の順番で指定してやらないといけない。

  • このエントリーをはてなブックマークに追加
  • Pocket

この記事へのコメントはこちら

メールアドレスは公開されませんのでご安心ください。
また、* が付いている欄は必須項目となりますので、必ずご記入をお願いします。

内容に問題なければ、下記の「コメント送信」ボタンを押してください。

seventeen + 6 =

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください